CineMoco Software Version 2.5

edited March 2016 in Axis360
Hi all!

The current version of the software for the Axis360 / CineMoco motor controller is now 2.5. You can download the latest version here: https://github.com/cinetics/CineMoco/archive/master.zip and follow the "Mac Automatic Update Instructions.pdf". To update on a Windows computer, you need to download Arduino version 1.0.6 ( https://www.arduino.cc/en/Main/OldSoftwareReleases ). Note: be careful with your controller's micro USB port! It is possible to break them on early controller versions.

2.5 Change List:

* Adds multi-axis moves in run mode, previously daisy chaining several controllers was restricted to keyframe mode.
* Speed setting in the motor menu saves properly. (Note: this is actually setting the microstepping for the motor, low = 1/8 step, med = 1/4 step, and high is 1/2 step.)
* Bounce mode renamed to Loop. This enables the motors to loop a move continuously.
* Setting for Sony camera added. Canon, Nikon, Panasonic, Sony and Other settings enable the camera trigger to operate properly for different camera makes.
* Bug fixed where master motor would not move after setting keyframes with the all motors function.
* Bug fixed where motor distance would not change properly in run mode.

Note: We were unable to include one feature that we hoped to in version 2.5; synchronized multiaxis moves in video mode. Currently, video mode will start all motors at the same time, but the end time varies based on the speed setting for each motor. Ideally, all motors would end at the same time. Video mode achieves its smooth motion by using simple code that does not report the motor position, which makes moving exact distances difficult. So there are two options: 1) use video mode and set the speed for each motor, or 2) use timelapse, continuous mode and set the run time for all of the motors. For option 2, setting the playback time to 1s and the FPS to 1 is advisable. Option 1 is a more quiet and option 2 ends all the motors in sync.

We look forward to your feedback!

Comments

  • Trying to upgrade to the 2.5 beta firmware. Any instruction available for this? I keep getting errors from Arduino software- 'error compiling' and this one..... (attached)
    image
  • Yeah been trying this Arduino upload thing for a few hours now- any way you can simplify this process? I've moved all of the 'hardware' into all the Arduino libraries as instructed but it doesn't want to work. Over my head.
    Should the Cinemoco controller be on or off while USB-connected to the computer? Or does it not matter. I've tried both options.
    You said Arduino 1.0.6, which is an old version- stick with that on or use the latest version (1.6.5). Again I've tried both- no luck.
    A video tutorial for firmware upgrade would be a huge help.
    Thanks.
  • Yeah, sorry the Arduino method is a little involved. I attached instructions that are also in the zip folder. Note that the software folder is updated to 2.5, and that this requires Arduino version 1.0.6 - https://www.arduino.cc/en/Main/OldSoftwareReleases
    Turn your controller off for the update, although I don't think it matters.
    We'll get the auto install programs updated shortly.
  • Ok, just updated the zip file in the first post to include the automatic update for Mac. The Windows auto update has not been updated yet.
  • Hey again,
    I just updated to version 2.5 on the Cinemoco. Unfortunately it does not fix the video/still trigger problem for the Lumix GH4 or Lumix G7. An earlier video from @Drew showed it working somehow- but I'm unable to replicate it.
  • Glad you got it uploaded! The Panasonic trigger is a strange issue. We've had it working properly on several cameras. It is likely some camera setting that we haven't quite pinned down. One person mentioned that it may have started working properly for him when he turned HDR off. We'll keep working in the GH4 thread to figure out what exactly is causing that.
  • i've tried also on mac and also on pc and i keep getting this msg -
    avrdude: stk500_getsync(): not in sync: resp=0x00
    can anyone help?
    btw even if the cinemoco switch is off when i connect it with the usb it turns on..
  • I'm not familiar with that error. You tried the Mac auto update and installed the VCP drivers and are stilling having issues?
  • How soon will full version will go live?
  • - Any news/updates?
    - Is there a direct link to updates at the cinetics.com-website?
  • There is a download to the updates in the comment on this page from August 5th, there is also an update to v2.5 on the github page located here https://github.com/cinetics/CineMoco
  • Hi Justin I'm ready for v2.5
    Is instruction for update vai AVR still the same as from V2.4?
    http://forum.cinetics.com/index.php?p=/discussion/140/2-4-auto-update-on-mac#latest
  • edited December 2015
    Hey guys, the files in the initial post of this thread are the final v2.5 and require a USB connection.

    @jellybobo, since you've updated with an AVR previously, your USB port should function properly and you can use USB this time.
  • Done. USB port works well on both moco and axis360 controller
  • 1. CW/ CCW function doesn't change rotation direction at all.
    2. Daisy-chain. Once operate, can not cancel all motor from master controller. need to manually cancel each controller otherwise it will not work properly when order it to move.
  • 3. Dragonframe- Jog Max speed 5,000 step /sec
    20,000 won't pull the belt
  • I have V2.4 & trying to upgrade to V2.5 on a MacBook Pro (with latest OS & updates) & either the mac autoupdate or the manual process with Arduino 1.0.6 did not work. I could not select the USB port in Arduino so I watched the /dev dir for cu* and nothing happened when I plugged in CineMoco (I also tried two different cables). Basically my Mac can not see the USB port...
  • Hi Greg, we can do the update in house for you for free if you purchased in the last 30 days or just for the price of shipping otherwise. Please send a message to info at cinetics dot com to arrange that :)
  • edited March 2016
    Hi Justin (or whoever!),
    It appears there is an error in the instructions. To open the miniE_cineMoco.ino file, I had to move the miniE_cineMoco folder into the Arduino folder. If I left it in the Download folder, Arduino 1.0.6 gave me an error message about not being able to open a file outside the main Arduino folder.

    Secondly, I saw that one of my controllers shows up in Devices&Printers as a "FT232R USB UART" on COM4, whereas the other two controllers show up as a "cineMoco" on COM3. Is that normal?

    Cheers,
    Roger
  • Hello Roger,

    The FT232R is the name of a usb chip which sits just on the other side of the usb port, so if it is not reading the controller as "cineMoco" it would make sense it would just read the name of the chip which is connected to the port. It should read "cineMoco" in Devices&Printers just like your other 2 controllers. It is strange that Arduino 1.0.6 needed the miniE_cineMoco folder to be inside the Arduino folder, I've experienced the Arduino IDE requiring the file being opened to have the same name as the folder it is in after I change IDE versions, such as from 1.5.8 back to 1.0.6. So in this case I think it would be good to just have the miniE_cineMoco folder in the Arduino folder as long as the upload is correct. But I think this could be a separate issue from the FT232R USB UART issue, which sounds much like a port that might need a driver update/refresher.
  • We just purchased the Two Axis360. We are trying to focus on a subject with a slide and pan move, but the CW/CCW setting isn't working. We've tried it in both time-lapse and video mode with the same result.

    Example: We have the master (slider) and controller #1 (pan/tilt) both set to video mode and run. We set up both controllers to move CW; however, after I hit play the pan/tilt controller pans the wrong direction (CCW). I stop the controller and go into the settings and it is set to CCW... every time I set it to CW and hit play... it reverts back to CCW.

    Jellybobo mentions this issue above, so I assume it's an inherent problem? Any chance of this getting fixed any time soon? Any update on synchronized multiaxis moves in video mode?

    Thanks,
    Scott
  • edited March 2016
    Hey guys, are you having the CW/CCW setting with the 2.5 version of the firmware linked to in the first post of this thread? This issue happened with a some 2.4 and beta 2.5 versions, but the current one should not see this problem.
  • I just updated 2 of my controllers. All worked fine. The third however i get the same error code as mossyair.
    avrdude: stk500_getsync(): not in sync: resp=0x00
    Justin, i know you said you hadn't seen that error code. Do you know if this was ever resolved?
    Thanks in advance,
    Bryce
  • @mossyair did you get the issue resolved?

    @BCWoodworks It would probably be best to send your problematic controller in to be updated with an AVR programmer. http://cinetics.com/controller-update/

Leave a Comment

Drop image/file