Unable to connect axis 360/Cinemoco v 2.5 to Dragonframe 3 or 4

Hi all, sorry for the long post, but I'll try to be detailed.

I just got an axis 360 slider and the 3 motors to do a slide/pan/tilt combo but it will not connect to Dragonframe in USB mode to control the motors. Version 2.5 of the Cinemoco software is installed on all 3 controllers. I tried following along with instructions and looked at forum for answers but no luck. I tried while all 3 controllers were turned on but separate, all 3 daisy chained and just 1 controller by itself but no luck. I also tried variations of having the controller plugged in/not plugged in to power source, and turned on/off. It looks like the USB is connected ok b/c the controller remains on when I plug in the USB to the computer, even if the controller is not plugged in or switched on. When only the USB is plugged in, the controller stays on but no power to the motors (as I read is normal from another post).

The problem I'm having is.. I connect USB cord and start Dragonframe and follow instructions to add controller but I get a failure message. I'm wondering if it has something to do with the connection or port I'm supposed to choose, or that I need another cord/connection. I have a Canon 5Ds that's connected to Dragonframe and I can see live view active. I don't have any DMC device or other connection from the camera to computer other than the camera cord I always use for Dragonframe. This is what the screen looks like when I start scene connections in Dragonframe: imagephoto Screen Shot 2017-07-28 at 2.41.40 PM_zpszp5ucrkx.png" alt="" />
I tried all 4 of the arcmoco connections. When I click connect in Dragonframe it goes to this port selection but there's only 1 port there for me to pick from: imagephoto Screen Shot 2017-07-28 at 9.01.31 PM_zps8vwsbo3t.png" alt="" />
I click ok and then right away select "start USB mode" on the Cinemoco controller. I also tried starting USB mode on the controller before trying to connect with Dragonframe but still no luck. When I switch the controller to USB mode, the motor kicks in and starts making the same continual sound that it makes if you were to turn on motor control option "keep powered". The Cinemoco screen shows this: imagephoto IMG_5555_zpsxzaq08tf.jpg" alt="" />
and the error I always get from Dragonframe version 3.6.8 is: imagephoto Screen Shot 2017-07-28 at 9.08.08 PM_zpscwzoqcla.png" alt="" />
I downloaded Dragonframe 4, but in that version I'm not sure what device to select for connections and tried most of them. Some options, when clicked, bring up another option bubble where you can select arcmoco #1 through 4, but nothing to select under location and when I click connect it does not work: imagephoto Screen Shot 2017-07-28 at 9.26.01 PM_zpspcxl0frh.png" alt="" />

I'm at a loss as to what else to try. I'm not sure if I'm missing some setting on my Canon 5dS or Dragonframe or if some other connection or device is required aside from the USB to the computer and camera cord to computer. I tried to find answers on Dragonframe's website but nothing there seemed to match up and I'm not sure if the Cinemoco is considered an arduino or not. If anyone can help I'd really appreciate it.

Thanks,
Matthew

Comments

  • Sorry I realized the pictures didn't go through. I was trying to use photobucket to make image URLs bur
  • Hi @Matthew_G you could try just drag and dropping the photos into you comment instead of using photobucket.

    Try charging up the controller and then unplugging the wall outlet, then connect via USB as described in the instructions. If you try this with more than one controller, and you are still having trouble, I'd recommend trying a different USB cable. Maybe that is the issue?

    Hope this is helpful!
  • Hi Justin,

    Thanks for getting back to me, I tried tried like you said and charged controllers and unplugged them from power and followed the connection instructions but still no luck. (in Dragonframe 3 or 4) I have 3 different usb cords that I tried, but none work. I also gave it another shot with the controller plugged in. There's a computer store near my house that opens soon and I am going to bring the controller to them and my cords to make sure there's nothing I'm missing. Here are the screen shots I tried to send before.

    1 - Dragonframe screen when I go to connect
    2 - Dragonframe - DFMoco serial port screen/prompt
    3 - screen of Cinemoco after i select USB mode
    4 - DF connection error prompt
    5 - DF version 4 screenshot of connection setup

    I'm wondering if it has something to do with the port? I guess the port mentions my iPhone because I've connected my cell to the computer before. I've tried plugging the USB cords into different ports on my Mac Pro terminal and also the monitor but nothing seems to work.
  • Matthew, sorry for my delay here.. Were you able to resolve this?

    I attached a pic of how the serial port shows up when this works properly. There could be some variation here depending on when your controller was made. I'm using Dragonframe 3.6.3.

    Sometimes you have to set the CineMoco controller into USB mode more than once during setup, so make sure the controller says "USB Mode" at the top.

Leave a Comment

Drop image/file